php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25055 Fatal error: Class 'com' not found
Submitted: 2003-08-12 09:04 UTC Modified: 2003-08-13 13:03 UTC
From: bart at mediawave dot nl Assigned:
Status: Not a bug Package: COM related
PHP Version: 5.0.0b1 (beta1) OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bart at mediawave dot nl
New email:
PHP Version: OS:

 

 [2003-08-12 09:04 UTC] bart at mediawave dot nl
Description:
------------
I got an error while trying to open Word through the COM class functions. I get an error like: "class com not found".

Reproduce code:
---------------
$word = new COM("word.application") or die ('Unable to instanciate Word');

Expected result:
----------------
Loading Word object into $word

Actual result:
--------------
class com not found

(I don't know the exact error message because I already installed PHP 4.3.2 to make it work)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-12 09:09 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2003-08-13 07:33 UTC] bart at mediawave dot nl
I've searched for hours and hours but didn't find anything anywhere! I've re-installed PHP5 to try and get to the bottom of this. But:

<?
$word = new COM("word.application") or die ('Unable to instanciate Word');
?>

keeps producing:

Fatal error: Class 'com' not found in E:\****\****.php on line xx

The exact same code on the exact same machine works perfectly with PHP 4.3.2 installed.

Does this mean that there's a new syntax to load a COM object? I tried all sorts of things but nothing works.
 [2003-08-13 13:03 UTC] sniper@php.net
There is no COM extension in PHP 5 (yet). So you can't really report any bugs about it either. Use PHP 4.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 18:03:46 2023 UTC