php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #24905 == operator is not transitive
Submitted: 2003-08-01 10:45 UTC Modified: 2004-05-22 11:22 UTC
From: tater at potatoe dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tater at potatoe dot com
New email:
PHP Version: OS:

 

 [2003-08-01 10:45 UTC] tater at potatoe dot com
Description:
------------
In other words, you cannot assume that if $a == $b and $b == $c, then $a == $c. (Because of type juggling - e.g. $a=0, $b='hi', $c=true.) This seems worth spelling out in the operators section, since it's not something people would expect, even though it is eventually covered implicitly elsewhere.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-22 11:22 UTC] nlopess@php.net
Duplicate of #23110.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 24 18:01:23 2021 UTC