php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24882 Failed opening phpinfo.php ... in Unknown on line 0
Submitted: 2003-07-31 08:16 UTC Modified: 2003-08-04 04:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mhawkins at ukeu dot com Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.3.2 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mhawkins at ukeu dot com
New email:
PHP Version: OS:

 

 [2003-07-31 08:16 UTC] mhawkins at ukeu dot com
Description:
------------
PHP works fine for a period, then fails on all php pages with the below error. This sometimes resolves itself after a few minutes, or sometimes is resolved by restarting the httpd. This occurs regardless of whether the php files are local or stored on nfs, so isn't a local network issue. This occurs intermittantly (and at different times) across two identically configured webservers. 

No changes to the php.ini have been made. Both webservers are under a very minimal load, and there are no cpu/memory/disk usage concerns. As far as I can tell, the file permissions in /opt/sunone/es/bin and /usr/local/php/lib/php are correct and unchanging, and the webservers have read or read/write permissions to all the required files.

Please email me if more information is required.

Previous Bugs (both seem to be the same error as this):

  #12995
  #7163

Platform:

  Solaris 8 (sparc)
  SunONE Webserver 6.0 sp5 (AKA iplanet/netscape)
  PHP 4.3.2
  GCC 2.95.3

Error output (displayed in browser):

  Warning: (null)(): Failed opening '/opt/sunone/es/docs/live/phpinfo.php' for inclusion (include_path='.:/usr/local/php/lib/php') in Unknown on line 0

phpinfo.php:

  <?php phpinfo(); ?>

configure:

  ./configure --prefix=/usr/local/php --with-mysql=/usr/local/mysql --with-nsapi=/opt/sunone/es --enable-track-vars --enable-libgcc

obj.conf (extract):

  <Object name="default">
  ...
  Service fn="php4_execute" type="magnus-internal/x-httpd-php"
  ...
  </Object>

  <Object name="x-httpd-php" 2=">">
  ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
  Service fn="php4_execute"
  </Object>

magnus.conf (extract):

  StackSize 131072
  Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/opt/sunone/es/bin/libphp4.so"
  Init fn=php4_init errorString="Failed to initialize PHP!"



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-31 08:21 UTC] thetaphi@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

This is a Solaris problem. It is fixed by the fd-lexer-patch which is included in PHP 4.3.3. If you do not want to use the latest snapshot, you can use PHP4.3.3 RC2, which you can download from PHP homepage.
Please read the nsapi-readme.txt before installing because the NSAPI module was improved in this version, too.
 [2003-07-31 08:36 UTC] mhawkins at ukeu dot com
Thanks for the update - I'll try out 4.3.3RC2, and will upgrade to 4.3.3 when it's released, if it fixes this.
 [2003-07-31 13:31 UTC] sniper@php.net
Let us know then if this works / does not work and set the status accordingly. (open/closed)

 [2003-08-04 04:22 UTC] mhawkins at ukeu dot com
Looks like it did the trick! Thanks for all your help...
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jun 20 16:01:30 2024 UTC