php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24850 Calling 3 times php using Apache Tomcat4.1.18 causes it's crash
Submitted: 2003-07-29 04:51 UTC Modified: 2003-07-29 05:55 UTC
From: javri28 at hotmail dot com Assigned:
Status: Not a bug Package: Java related
PHP Version: 4.3.2 OS: Windows 2k prof.
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: javri28 at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-07-29 04:51 UTC] javri28 at hotmail dot com
Description:
------------
Calling 3 times PHP using Apache Tomcat4.1.18 causes it's crash. It doesn't metter are you calling one file all the time(pressing F5 3 times) or different ones: 1.php, 2.php, 3.php; When calling 3.php Tomcat is daid and browser's message "can not find specified resource..." appears.

Reproduce code:
---------------
<html>
<head>
<title>PHP Test Page</title>
</head>
<body>
 T E S T
 <?= 'Hello, cruel world!' ?>
<hr>
</body>
</html>


Actual result:
--------------
An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : EXCEPTION_ACCESS_VIOLATION occurred at PC=0x11D2E84B
Function=zend_hash_add_or_update+0xAB
Library=C:\Programme\PHP4.3.2\php4ts.dll

Current Java thread:
	at net.php.servlet.send(Native Method)
	at net.php.servlet.service(servlet.java:190)
	at net.php.servlet.service(servlet.java:214)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter
(ApplicationFilterChain.java:247)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter
(ApplicationFilterChain.java:193)
	at org.apache.catalina.core.StandardWrapperValve.invoke
(StandardWrapperValve.java:260)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:643)
	at org.apache.catalina.core.StandardPipeline.invoke
(StandardPipeline.java:480)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
	at org.apache.catalina.core.StandardContextValve.invoke
(StandardContextValve.java:191)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:643)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke
(AuthenticatorBase.java:550)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:641)
	at org.apache.catalina.valves.CertificatesValve.invoke
(CertificatesValve.java:246)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:641)
	at org.apache.catalina.core.StandardPipeline.invoke
(StandardPipeline.java:480)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
	at org.apache.catalina.core.StandardContext.invoke
(StandardContext.java:2415)
	at org.apache.catalina.core.StandardHostValve.invoke
(StandardHostValve.java:180)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:643)
	at org.apache.catalina.valves.ErrorDispatcherValve.invoke
(ErrorDispatcherValve.java:170)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:641)
	at org.apache.catalina.valves.ErrorReportValve.invoke
(ErrorReportValve.java:172)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:641)
	at org.apache.catalina.valves.AccessLogValve.invoke
(AccessLogValve.java:509)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:641)
	at org.apache.catalina.core.StandardPipeline.invoke
(StandardPipeline.java:480)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
	at org.apache.catalina.core.StandardEngineValve.invoke
(StandardEngineValve.java:174)
	at 
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNex
t(StandardPipeline.java:643)
	at org.apache.catalina.core.StandardPipeline.invoke
(StandardPipeline.java:480)
	at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
	at org.apache.catalina.connector.http.HttpProcessor.process
(HttpProcessor.java:1040)
	at org.apache.catalina.connector.http.HttpProcessor.run
(HttpProcessor.java:1151)
	at java.lang.Thread.run(Thread.java:536)

Dynamic libraries:
0x00400000 - 0x00406000 	C:\java\jdk\bin\java.exe
0x77880000 - 0x77901000 	C:\WINNT\System32\ntdll.dll
0x77DA0000 - 0x77DFB000 	C:\WINNT\system32\ADVAPI32.dll
0x77E70000 - 0x77F32000 	C:\WINNT\system32\KERNEL32.DLL
0x77D30000 - 0x77DA0000 	C:\WINNT\system32\RPCRT4.DLL
0x78000000 - 0x78046000 	C:\WINNT\system32\MSVCRT.dll
0x6D450000 - 0x6D6AD000 	C:\java\jdk\jre\bin\server\jvm.dll
0x77E00000 - 0x77E64000 	C:\WINNT\system32\USER32.dll
0x77F40000 - 0x77F7C000 	C:\WINNT\system32\GDI32.DLL
0x77540000 - 0x77571000 	C:\WINNT\System32\WINMM.dll
0x6D1D0000 - 0x6D1D7000 	C:\java\jdk\jre\bin\hpi.dll
0x6D300000 - 0x6D30D000 	C:\java\jdk\jre\bin\verify.dll
0x6D210000 - 0x6D228000 	C:\java\jdk\jre\bin\java.dll
0x6D320000 - 0x6D32D000 	C:\java\jdk\jre\bin\zip.dll
0x6D2D0000 - 0x6D2DD000 	C:\java\jdk\jre\bin\net.dll
0x74FC0000 - 0x74FC9000 	C:\WINNT\System32\WSOCK32.dll
0x74FA0000 - 0x74FB3000 	C:\WINNT\System32\WS2_32.DLL
0x74F90000 - 0x74F98000 	C:\WINNT\System32\WS2HELP.DLL
0x74F40000 - 0x74F5F000 	C:\WINNT\system32\msafd.dll
0x74F80000 - 0x74F87000 	C:\WINNT\System32\wshtcpip.dll
0x77830000 - 0x7783C000 	C:\WINNT\System32\rnr20.dll
0x77970000 - 0x77994000 	C:\WINNT\System32\DNSAPI.DLL
0x77310000 - 0x77323000 	C:\WINNT\System32\iphlpapi.dll
0x774F0000 - 0x774F5000 	C:\WINNT\System32\ICMP.DLL
0x772F0000 - 0x77307000 	C:\WINNT\System32\MPRAPI.DLL
0x750C0000 - 0x750D0000 	C:\WINNT\System32\SAMLIB.DLL
0x750E0000 - 0x7512F000 	C:\WINNT\System32\NETAPI32.DLL
0x77BD0000 - 0x77BDF000 	C:\WINNT\System32\SECUR32.DLL
0x75130000 - 0x75136000 	C:\WINNT\System32\NETRAP.DLL
0x77940000 - 0x7796A000 	C:\WINNT\system32\WLDAP32.DLL
0x77A40000 - 0x77B36000 	C:\WINNT\system32\OLE32.DLL
0x779A0000 - 0x77A3B000 	C:\WINNT\system32\OLEAUT32.DLL
0x77380000 - 0x773AF000 	C:\WINNT\System32\ACTIVEDS.DLL
0x77350000 - 0x77372000 	C:\WINNT\System32\ADSLDPC.DLL
0x77820000 - 0x7782E000 	C:\WINNT\System32\RTUTILS.DLL
0x78310000 - 0x783A0000 	C:\WINNT\System32\SETUPAPI.DLL
0x77C00000 - 0x77C5E000 	C:\WINNT\System32\USERENV.DLL
0x774B0000 - 0x774E2000 	C:\WINNT\System32\RASAPI32.DLL
0x77490000 - 0x774A1000 	C:\WINNT\System32\RASMAN.DLL
0x77500000 - 0x77522000 	C:\WINNT\System32\TAPI32.DLL
0x77B40000 - 0x77BC9000 	C:\WINNT\system32\COMCTL32.DLL
0x77C60000 - 0x77CAA000 	C:\WINNT\system32\SHLWAPI.DLL
0x77330000 - 0x77349000 	C:\WINNT\System32\DHCPCSVC.DLL
0x784A0000 - 0x78525000 	C:\WINNT\System32\CLBCATQ.DLL
0x777D0000 - 0x777D8000 	C:\WINNT\System32\winrnr.dll
0x777E0000 - 0x777E5000 	C:\WINNT\System32\rasadhlp.dll
0x11C70000 - 0x11C76000 	C:\Programme\PHP4.3.2\sapi\phpsrvlt.dll
0x11C80000 - 0x11DC9000 	C:\Programme\PHP4.3.2\php4ts.dll
0x1F7F0000 - 0x1F825000 	C:\WINNT\System32\ODBC32.dll
0x76B00000 - 0x76B3F000 	C:\WINNT\system32\comdlg32.dll
0x77580000 - 0x777C8000 	C:\WINNT\system32\SHELL32.DLL
0x1F8E0000 - 0x1F8F6000 	C:\WINNT\System32\odbcint.dll
0x60000000 - 0x60045000 	C:\WINNT\System32\MSCTF.dll
0x77910000 - 0x77933000 	C:\WINNT\system32\imagehlp.dll
0x72970000 - 0x7299D000 	C:\WINNT\system32\DBGHELP.dll
0x68F30000 - 0x68F3B000 	C:\WINNT\System32\PSAPI.DLL

Local Time = Thu Jul 24 14:09:17 2003
Elapsed Time = 70
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Server VM (1.4.0_01-b03 mixed mode)
#

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-29 05:54 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Try search the bug database first before submitting new reports about same issue. (Try the "Java related" category for example). Java/servlet support is really experimental and hasn't worked for a long time..

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 16:03:35 2021 UTC