php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24814 Including URLs with ports does not work.
Submitted: 2003-07-25 22:18 UTC Modified: 2003-07-26 12:19 UTC
From: mistermarvelous at hotmail dot com Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.3.2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mistermarvelous at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-07-25 22:18 UTC] mistermarvelous at hotmail dot com
Description:
------------
Ok when I try to include, readfile, fopen or any function of that type, I get a error if the port is in the url.

For example
http://68.88.56.41:2525/index.html doesnt work.

but something like
http://www.google.com/index.html does work.

I don't know if this is a bug or a missing feature, but I am not able to get this to work at all.

Reproduce code:
---------------
<?php
include("http://68.88.56.41:2525/index.html");
?>

Expected result:
----------------
Warning: main(http://68.88.56.41:2525/index.html): failed to open stream: HTTP request failed! in C:\web\spherestatus.php on line 2

Warning: main(): Failed opening 'http://68.88.56.41:2525/index.html' for inclusion (include_path='.;c:\php4\pear') in C:\web\spherestatus.php on line 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-26 12:19 UTC] pollita@php.net
I can't reproduce this with either 4.3.2 (Tried with Linux and Windows) or the most recent snapshot.

<?php
  readfile("http://socrates.berkeley.edu:4100/");
?>

The above works as expected.  However, when trying to visit the url you provided: http://68.88.56.41:2525/index.html not only can I not reach it via php, I don't see anything through IE, Netscape or Mozilla.  (Presumably this is your server and it's offline?)

If you can reliably reproduce this bug, please reopen it with additional information.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 12:03:37 2021 UTC