php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24793 dlopen error: libphp4.so No such file or directory
Submitted: 2003-07-24 10:28 UTC Modified: 2003-09-10 12:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: alibarim at yahoo dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.3.3RC5-dev OS: AIX 433
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: alibarim at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-07-24 10:28 UTC] alibarim at yahoo dot com
Description:
------------
I try to use the PDFLib from (www.pdflib.com) and PHP 4.3.2

Here is my configure for PDFLib:

./configure  \
  --prefix=/apps/local/apache_test_Ali/lib/pdf \
  --enable-php \
  --with-java=no \
  --with-tcl=no \
  --with-py=no \
  --with-perl=no


Here is my configure for PHP:

./configure  \
  --prefix=/apps/local/php-4.3.2/ \
  --without-mysql \
  --with-sybase-ct=/usr/sybase \
  --with-apxs=/apps/local/apache_test_Ali/bin/apxs \
  --with-pdflib=/apps/local/apache_test_Ali/lib/pdf \
  --enable-sysvmsg \
  --enable-inline-optimization


I rebuild PHP and everything seem to be ok.

But I cannot run my Apache server.

Starting WWW-Server apache.
Syntax error on line 67 of /apps/local/apache_test_Ali/conf/httpd.conf.kplus20:
Cannot load /apps/local/apache_test_Ali/libexec/libphp4.so into server: dlopen: /apps/local/apache_test_Ali/libexec/libphp4.so: No such file or directory



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-24 12:59 UTC] iliaa@php.net
Are there any libphp4* files inside the /apps/local/apache_test_Ali/libexec/ directory?
 [2003-07-24 14:10 UTC] alibarim at yahoo dot com
Yes.
I have one libphp4.so.4.2.3 and one libphp4.3.2

and a symbolic link libphp4.so on one of these library.
When I switch to libphp4.2.3 (comipled exactly with the same configure options). I can run Apache correctly.

But is not the case with the 4.3.2
 [2003-07-25 03:29 UTC] alibarim at yahoo dot com
As you suggest, I try the http://snaps.php.net/php4-STABLE-latest.tar.gz

Unfortunatly the problem seem to be the same !

Cannot load /apps/local/apache_test_Ali/libexec/libphp4.so into server: dlopen: /apps/local/apache_test_Ali/libexec/libphp4.so: No such file or directory


I have also to remove the external gd (2.0.7) library from my configure. I got an undefined symbol for gdFreeFontCache.
 [2003-07-25 06:16 UTC] sniper@php.net
I don't know if AIX has 'ldd' command, but if it does,
what does 'ldd libphp4.so' output?

 [2003-07-25 07:27 UTC] alibarim at yahoo dot com
It seems that ldd on AIX does not work correctly.
However, the output is:

ldd libphp4.so
libphp4.so: No such file or directory

We use the dump command on AIX. The output is.

dump -H libphp4.so 

libphp4.so:

                        ***Loader Section***
                      Loader Header Information
VERSION#         #SYMtableENT     #RELOCent        LENidSTR
0x00000001       0x000008be       0x00004a3c       0x00000092       

#IMPfilID        OFFidSTR         LENstrTBL        OFFstrTBL
0x00000006       0x00044cc0       0x0000a233       0x00044d52       


                        ***Import File Strings***
INDEX  PATH                          BASE                MEMBER              
0      /apps/local/apache_test_Ali/lib/pdf/lib:/usr/sybase/lib:/usr/lib:/lib                                         
1                                    libpdf.a            libpdf.so.1         
2                                    libc.a              shr.o               
3                                    libgcc_s.a          shr.o               
4                                    librtl.a            shr.o               
5                                    .
 [2003-08-08 18:50 UTC] sniper@php.net
Get the latest stable CVS snapshot and try this configure line:

./configure  \
  --prefix=/apps/local/php-4.3.2/ \
  --disable-all \
  --with-apxs=/apps/local/apache_test_Ali/bin/apxs \
  --with-pdflib=/apps/local/apache_test_Ali/lib/pdf 


 [2003-08-18 09:55 UTC] alibarim at yahoo dot com
As you suggset, I try your configure command.
Unfortunatly the result is the same !

ie:

Cannot load /apps/local/apache_test_Ali/libexec/libphp4.so into server: dlopen: /apps/local/apache_test_Ali/libexec/libphp4.so: No such file or directory
 [2003-08-18 10:37 UTC] sniper@php.net
Add --disable-cli to that configure line. See also bug #25058
(it's for apache2 but pretty much same issue, AIX too)

 [2003-08-19 02:30 UTC] alibarim at yahoo dot com
I add --disable-cli as you suggest. But the problem is the same.

Starting WWW-Server apache.
Syntax error on line 67 of /apps/local/apache_test_Ali/conf/httpd.conf.kplus20:
Cannot load /apps/local/apache_test_Ali/libexec/libphp4.so into server: dlopen: /apps/local/apache_test_Ali/libexec/libphp4.so: No such file or directory
 [2003-08-19 04:21 UTC] sniper@php.net
Did you do 'rm config.cache' and 'make clean' before that?
Also, did you read all the comments in bug #25058?
Especially the part about copying the libphp4.so manually..

 [2003-08-19 05:15 UTC] alibarim at yahoo dot com
Yes I do.
Before any compilation, I do a make distclean.

Concerning the comments on bug #25058. I read it, but I did'nt see any particular point. 

I just copy de libphp4.so into my libexec directory. As I done it for the 4.2.3 version
 [2003-08-19 05:27 UTC] sniper@php.net
Well, did it work when you manually copied the file?
(even without the --disable-cli maybe?)

 [2003-08-19 07:31 UTC] alibarim at yahoo dot com
When I use the following configure commad, and copy manually the compiled library, everything is OK and Apache run normally.

#!/bin/sh


exec configure \
  --prefix /apps/local/php-4.3.2/ \
  --disable-all \
  --disable-cli \
  --with apxs=/apps/local/apache_test_Ali/bin/apxs

When I add the pdf 

 --with-pdflib=/apps/local/apache_test_Ali/lib/pdf

Apache cannot run !!

Cannot load /apps/local/apache_test_Ali/libexec/libphp4.so into server:
dlopen: /apps/local/apache_test_Ali/libexec/libphp4.so: No such file or
directory

This is not the case with the 4.2.3 version.
 [2003-09-09 18:00 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

And this time try with your normal configure line for PHP.
I don't think 'make install' will work yet, but you shouldn't need --disable-cli anymore.

 [2003-09-10 08:13 UTC] alibarim at yahoo dot com
I download the recommanded version.
I should add to my configure command

--disable-cli
--without-pear

And now when I try to run Apache, I obtain:

./apache[23]: 58706 Illegal instruction

It seems to be a core dumped for Apache.
When I remove LoadModule php4 from my httpd.conf everything
seems to be ok and Apache run normally.
 [2003-09-10 12:33 UTC] alibarim at yahoo dot com
The problem is resolved now.
I download the 4.3.3 available on the web Site and compile it with gcc version 3.2.3.

With this verison of gcc when you include the PDFLib you have to put the libgcc_s.a in one of the directory figuring in the output of dump -H on libphp4.so

Everything is OK now.
Thanks to all for your participation.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 21:05:44 2022 UTC