php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24664 relocation error: symbol not found: ap_pass_brigade
Submitted: 2003-07-15 08:30 UTC Modified: 2003-10-30 21:16 UTC
From: a dot polli at mir dot it Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4.3.3RC4-dev OS: OpenUnix 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: a dot polli at mir dot it
New email:
PHP Version: OS:

 

 [2003-07-15 08:30 UTC] a dot polli at mir dot it
Description:
------------
I have this error when I start apache2 (2.0.46) with php4 (4.3.2)

Syntax error on line 233 of /mypath/apache2/conf/httpd.conf:
Cannot load /mypath/apache2/modules/libphp4.so into server: dynamic linker:
/mypath/apache2/bin/httpd: relocation error: symbol not found:
ap_pass_brigade; referenced from: /mypath/apache2/modules/libphp4.so


I compile apache 2.0.46 with

./configure --prefix=/mypath/apache2 
--enable-modules="ssl dav mime-magic
auth-anon auth-dbm auth-digest cern-meta expires headers usertrack unique-id
proxy info cgi vhost-alias rewrite so speling"

and then php 4.3.2 with

./configure  --with-apxs2=/mypath/apache2/bin/apxs 
--with-pgsql=/mypath/pgsql 
--with-mysql=/mypath/mysql 
--with-zlib 
--with-gd 
--with-ftp 
--with-xml



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-16 03:15 UTC] a dot polli at mir dot it
I try it (php4-STABLE-200307160530),
but I have the same error when I start apache2.
 [2003-07-16 04:05 UTC] sniper@php.net
Have you tried Apache 1.3.27 which might actually work?

 [2003-07-16 07:38 UTC] a dot polli at mir dot it
I try with apache 1.3.27 and it works (I can see a phpinfo page ...)
yes, I think it's a Apache2 related problem
 [2003-07-17 22:47 UTC] sniper@php.net
What does this output:

# nm -g httpd |grep pass_brig

(for Apache2, of course :)

 [2003-07-18 01:03 UTC] a dot polli at mir dot it
# nm -g httpd |grep pass_brig
[5540]    |135086056 |141       |FUNC |GLOB |0    |9      |ap_pass_brigade
[5988]    |135848628 |4         |OBJT |GLOB |0    |15     |ap_hack_ap_pass_brigade
 [2003-07-21 18:06 UTC] iliaa@php.net
Make sure that you have only 1 set of Apache 2 headers on your system. You can do so by looking for instances of the ap_mpm.h header.
 [2003-07-22 05:22 UTC] a dot polli at mir dot it
I delete all previous version of apache2 and I try the new version (2.0.47) with php4-STABLE-200307220930.
apache2 alone works fine.
apache2 with php: same error

# nm -g httpd |grep pass_brig
[5550]    |135087100 |141       |FUNC |GLOB |0    |9      |ap_pass_brigade
[5999]    |135851688 |4         |OBJT |GLOB |0    |15     |ap_hack_ap_pass_brigade
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 14:04:16 2022 UTC