php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24661 xmlCleanupParser called multiple times and causes crash
Submitted: 2003-07-15 05:16 UTC Modified: 2003-07-16 06:24 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: wez@php.net Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 5CVS-2003-07-15 (dev) OS: win32
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: wez@php.net
New email:
PHP Version: OS:

 

 [2003-07-15 05:16 UTC] wez@php.net
Description:
------------
dom, simplexml etc. all call xmlCleanupParser in their MSHUTDOWN functions and cause a crash.

Reproduce code:
---------------
Just run any simple script under the debugger to catch the exception - it doesn't even need to use xml related functions.

Expected result:
----------------
No crash ;)

Actual result:
--------------
Death

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-15 13:48 UTC] cw at centerwave dot de
Could be the reason for #24634?
 [2003-07-15 13:51 UTC] rrichards@php.net
You wouldn't happen to be using libxml2-2.5.8 would you?
 [2003-07-15 14:23 UTC] wez@php.net
libxml2-2.5.7.win32, downloaded from xmlsoft site with dlls installed into C:\WINDOWS\SYSTEM32 under winxp pro.

Curiously, it only appears to be a visible problem when running under the debugger (cli SAPI).
 [2003-07-16 06:24 UTC] rrichards@php.net
The problem is with libxml in the 2.5.7 and 2.5.8 releases. I submitted a fix, so it is fixed in the their cvs tree. PHP needs to be built with either a pre 2.5.7 version or a build from the latest cvs.

Note: libxml 2.5.7 built directly from the tar.gz file does not have the problem as the windows binary of libxml is built from cvs after some testing of the libxml release so contains updated code.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 05:05:53 2022 UTC