php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #24443 GD support for CYMK jpg files
Submitted: 2003-07-01 13:46 UTC Modified: 2016-09-05 11:33 UTC
From: seth at robustai dot net Assigned: cmb (profile)
Status: Closed Package: GD related
PHP Version: * OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: seth at robustai dot net
New email:
PHP Version: OS:

 

 [2003-07-01 13:46 UTC] seth at robustai dot net
Description:
------------
I get the following error when attempting to use this function on a CYMK jpg image.

Warning: imagecreatefromjpeg(): '/usr/local/www/vhosts/speaktomecatalog.com/htdocs/highRes/3STOOG.jpg' is not a valid JPEG file in /usr/local/www/vhosts/speaktomecatalog.com/htdocs/db/eproduct.html on line 153

But the same function works fine when the image is a RGB image.   

Is this a bug, or does the GD package just not support CYMK images ?

Thanks for your assistance.
Seth Russell



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-07-01 14:14 UTC] derick@php.net
Not a bug (it is just not supported); so we make it a feature request.
 [2014-04-16 18:50 UTC] levim@php.net
-Status: Open +Status: Feedback -Package: Feature/Change Request +Package: GD related -Operating System: free bsd +Operating System: Any -PHP Version: 4.3.2 +PHP Version: *
 [2014-04-16 18:50 UTC] levim@php.net
I think GD added support for implicit CMYK to RGB conversion; does anyone know for sure? I'm having trouble finding information.
 [2014-04-16 20:50 UTC] pajoye@php.net
-Status: Feedback +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2014-04-22 06:19 UTC] romtek at gmail dot com
GD extension already provides basic CMYK support. See http://www.boutell.com/gd/manual2.0.26.html#whatsnew2.0.22
 [2016-09-05 11:33 UTC] cmb@php.net
-Status: Assigned +Status: Closed -Assigned To: pajoye +Assigned To: cmb
 [2016-09-05 11:33 UTC] cmb@php.net
Indeed, CMYK is supported as of GD 2.0.22, which has been bundled
with PHP 4.3.6, see <http://php.net/ChangeLog-4.php#4.3.6>.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 18:03:43 2023 UTC