php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24382 COM returns bad characters
Submitted: 2003-06-29 07:05 UTC Modified: 2003-06-29 09:23 UTC
From: yossb at nirlat dot co dot il Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.2 OS: Win2000pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yossb at nirlat dot co dot il
New email:
PHP Version: OS:

 

 [2003-06-29 07:05 UTC] yossb at nirlat dot co dot il
Description:
------------
We are using OLE with DLL files, Writen VB, and compiled as COM . 
No problem to get from the OLE all English&Digits, but the Hebrew chars we get : ?????????. ( ASCII 63 )
We expected to get from ASCII  224 To ASCII 250.
If we send Hebrew string directly from PHP we get Hebrew ok.
 ( We check the OLE and the DLL in ASP & IIS . We get the Hebrew OK. ) 
We are using APACHE 1.3 & PHP 4.3.2. 
It looks like Bug #9263.
We tried to write:
 $com = new COM ( "D_dll.OleDll", "localhost", CODEPAGE DEAFULT CP_UTF8 )
We get compiler ERR "....unexpected T_STRING..."

Please help ! thanks 



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-29 09:23 UTC] sniper@php.net
RTFM:

string COM::COM ( string module_name [, string server_name [, int codepage]])

..

"codepage

specifies the codepage that is used to convert php-strings to unicode-strings and vice versa. Possible values are CP_ACP, CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP, CP_UTF7 and CP_UTF8."

The line should read:

$com = new COM ("D_dll.OleDll", "localhost", CP_UTF8);

(Disclaimer: I've NEVER used COM, I don't do windows :)

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 04:03:45 2023 UTC