php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2430 memory leaks in zend
Submitted: 1999-10-03 09:31 UTC Modified: 1999-10-09 15:31 UTC
From: Danny dot Heijl at cevi dot be Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Latest CVS (03/10/1999) OS: Linux RH 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Danny dot Heijl at cevi dot be
New email:
PHP Version: OS:

 

 [1999-10-03 09:31 UTC] Danny dot Heijl at cevi dot be
Just back from a 3 week holiday.
Checked out and built latest CVS.
I ported the PHP3 "make test" to my php4 directory, and all tests run fine
with php4 except one :

classes/class_example.php3t: Classes general test   

zend_hash.c(190) :  Freeing 0x08230378 (4 bytes), script=./php.in
Last leak repeated 3 times
zend_hash.c(180) :  Freeing 0x08230318 (45 bytes), script=./php.in
Last leak repeated 3 times
zend_hash.c(100) :  Freeing 0x08230108 (20 bytes), script=./php.in
zend_execute.c(1492) :  Freeing 0x082300A8 (44 bytes), script=./php.in
zend_variables.c(142) : Actual location (location was relayed)
zend_execute.c(1490) :  Freeing 0x08230068 (12 bytes), script=./php.in

....passed

This script ran fine 3 weeks ago with the then current CVS .

Also, the Informix driver now dumps core but I see that there have been 
al lot of changes in zend, I will have a look at them first.

Danny.
---

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-10-04 14:56 UTC] danny at cvs dot php dot net
I would if I could, but I can no longer build php4 on RH 56.0 :

buildconf :
buildconf: checking installation...
buildconf: autoconf version 2.13 (ok)
buildconf: automake version 1.4 (ok)
buildconf: libtool version 1.3.3 (ok)
buildconf: created or modified aclocal.m4
automake: configure.in: installing `./install-sh'
automake: configure.in: installing `./mkinstalldirs'
automake: configure.in: installing `./missing'
configure.in: 729: required file `./$PHP_OUTPUT_FILES.in' not found
automake: ./libzend/Makefile.am: C++ source seen but `CXX' not defined in `configure.in'
buildconf: created or modified configure
buildconf: created or modified libzend/aclocal.m4
buildconf: created or modified libzend/configure
buildconf: created or modified TSRM/aclocal.m4
buildconf: created or modified TSRM/configure

configure then gives this error :
...snip...
checking whether build environment is sane... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for bison... (cached) bison -y
checking bison version... 1.27 (ok)
checking for gcc... (cached) gcc
checking whether the C compiler (gcc -O2 -mpentium -g -Wall 
  -I/opt/informix/incl/esql -L/home/local/lib -L/opt/informix/lib 
  -L/opt/informix/lib/esql -module) works... no
configure: error: installation or configuration problem: C compiler cannot
 create executables.
cd . \
  && CONFIG_FILES= CONFIG_HEADERS=php_config.h \
     /bin/sh ./config.status
creating php_config.h
php_config.h is unchanged
+ test -d libzend
+ cd libzend
+ /home/web/php/php4/./libzend/configure --cache-file=.././config.cache
  --prefix=/home/local/php 
  --enable-track-vars 
  --enable-debug 
  --enable-static 
  --enable-bcmath 
  --with-gd=/home/local 
  --with-xml=/home/local 
  --with-gdbm 
  --with-zlib=/home/local 
  --with-config-file-path=/home/local/apache/etc/ 
  --with-informix=yes 
  --disable-static
...snip...

Note this last --disable-static : I did not specify that !  I don't know where it 
comes from. I tried adding --enable-static but it doesn't help.

Danny
---

 [1999-10-05 15:16 UTC] andi at cvs dot php dot net
Can you please see if those memory leaks have gone away from you after updating libzend.
 [1999-10-06 13:45 UTC] andi at cvs dot php dot net
I have fixed this leak. Please update your CVS tree and see if it's OK.
Thanks for the report.
 [1999-10-09 15:31 UTC] andi at cvs dot php dot net
Should be fixed in latest CVS. Update your libzend dir, do a make clean before recompiling and see if it's fixed. If not, please reopen the bug report.
Thanks!
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC