php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24293 $REQUEST_URI does not get filled
Submitted: 2003-06-23 03:00 UTC Modified: 2003-06-23 12:51 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: giupnol at freemail dot it Assigned:
Status: Closed Package: Variables related
PHP Version: 4.3.3RC1 OS: Windows XP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: giupnol at freemail dot it
New email:
PHP Version: OS:

 

 [2003-06-23 03:00 UTC] giupnol at freemail dot it
Description:
------------
$REQUEST_URI==""
Simply that. I use this global variable in order to keep history of the pages visited by the users, so i discovered this bug.

Reproduce code:
---------------
<?
echo $REQUEST_URI;
?>

Expected result:
----------------
/some_location/some_page.html

Actual result:
--------------
NONE

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-23 09:58 UTC] pollita@php.net
I'm assuming that this condition came about after an upgrade.  Very likely an upgrade from a version in which register_globals was defaulted to on.  Since 4.3.3 has register globals off that would explain your problem.

Try referencing the variable as $_SERVER['REQUEST_URI'] or setting register_globals=on in your php.ini (and restarting your webserver).

 [2003-06-23 12:41 UTC] giupnol at freemail dot it
Regarding the previous feedback. Unfortunately register_globals is turned on. So this is probably still a bug.
 [2003-06-23 12:51 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 00:01:27 2019 UTC