php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24237 number_format / printf problem
Submitted: 2003-06-17 23:03 UTC Modified: 2003-06-18 10:02 UTC
From: stiangarthus at hotmail dot com Assigned:
Status: Not a bug Package: *Math Functions
PHP Version: 4.3.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stiangarthus at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-06-17 23:03 UTC] stiangarthus at hotmail dot com
Description:
------------
Have only experienced this problem on one server. Fresh php installation, standard php.ini.

Configure line: 
./configure' '--with-mysql=/usr/local/mysql' '--with-apache=/usr/local/src/www/apache_1.3.27' '--with-openssl=/usr' '--enable-track-vars' '--enable-force-cgi-redirect' '--with-gettext' 

Reproduce code:
---------------
$num = 4;
$num = number_format($num, 2);
echo "$num<br>";
$num = 4;
printf ("%.2f", $num);

Expected result:
----------------
4.00
4.00

Actual result:
--------------
0.00
0.00

http://www.yosearch.com/test1.php <- code here
http://www.yosearch.com/test.php <- phpinfo() here

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-18 10:02 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Unable to replicate, possibly the result of overoptimizations in gentoo.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 04:01:24 2020 UTC