php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24231 Self Contained Extension sybase_ct won't config
Submitted: 2003-06-17 20:32 UTC Modified: 2003-06-18 13:29 UTC
From: lbayuk at mindspring dot com Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.3.2 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lbayuk at mindspring dot com
New email:
PHP Version: OS:

 

 [2003-06-17 20:32 UTC] lbayuk at mindspring dot com
Description:
------------
Attempt to convert sybase_ct extension into a Self Contained Extension doesn't work anymore since the configuration
of sybase_ct checks to make sure the sybase extension
wasn't also configured. That check fails when the extention is converted to be Self-Contained.

Reproduce code:
---------------
After "phpize":
$ ./configure --with-php-config=/opt/php/bin/php-config \
              --with-sybase-ct=shared,/opt/freetds


Expected result:
----------------
(Should configure properly)

Actual result:
--------------
   checking for Sybase-CT support... yes, shared
   configure: error: You can not use both --with-sybase and --with-sybase-ct in same build!

(No, adding --without-sybase or similar does not fix it, but adding "export PHP_SYBASE=no" before configure does.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-18 13:29 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jun 24 07:01:25 2021 UTC