php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24223 imagettftext does not work
Submitted: 2003-06-17 08:12 UTC Modified: 2003-06-17 08:38 UTC
From: kyojee at hotmail dot com Assigned: iliaa (profile)
Status: Closed Package: GD related
PHP Version: 4.3.2 OS: Solaris
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kyojee at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-06-17 08:12 UTC] kyojee at hotmail dot com
Description:
------------
because below codes

char *next is always NULL.


Reproduce code:
---------------
ext/gd/libgd/gdft.c

line: 890

#ifndef JISX0208
	if (!font->have_char_map_sjis) {
		next = string;
	} else
#endif
		tmpstr = (char *) gdMalloc(BUFSIZ);

	while (*next) {     /* segmenntation fault at here */
		ch = *next;


Expected result:
----------------
#ifndef JISX0208
	if (!font->have_char_map_sjis) {
		next = string;
	} else
#endif
		tmpstr = (char *) gdMalloc(BUFSIZ);
        next = string;  /* my fixed */
	while (*next) {
		ch = *next;



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-17 08:38 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Oct 17 03:01:27 2019 UTC