php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2417 When some client POST a request with "short" boundary -- php return error
Submitted: 1999-10-01 08:09 UTC Modified: 2002-06-16 08:58 UTC
From: pfroment at gemme dot net Assigned:
Status: Not a bug Package: Parser error
PHP Version: 3.0.12 OS: Solaris 2.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pfroment at gemme dot net
New email:
PHP Version: OS:

 

 [1999-10-01 08:09 UTC] pfroment at gemme dot net
With php 3.x and php4 when you parse POST messgae, you don't test the "complete boundary" ( i.e --boundary) for each kind off DataType 
But some "CGI client" like perl 5.0.x check complete boundary for validate his send (ie they test if --$boundary is not present in DATA sending).
In the case of perl, I report the problem because the default boundary is "000" (Zero..Zero).
So when I send MultiPart and Field with alue equal to "X000" (like Y2K --> 2000) php don't receive all data and hang up.

I check PHP3 (mime.c) and PHP4 beta 2 (rfc1867.c) the problem is the same.
Could you make some think to correct this feature, Like NEWBOUNDARY.

Best Regards.
Pascal FROMENT
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:58 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu May 23 14:01:34 2019 UTC