php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2414 php3_vmailmgr.so refuses to load
Submitted: 1999-09-30 16:36 UTC Modified: 2002-06-16 08:58 UTC
From: tmcqueen at homefusion dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 3.0.12 OS: RedHat Linux 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
1 + 33 = ?
Subscribe to this entry?

 
 [1999-09-30 16:36 UTC] tmcqueen at homefusion dot net
Apache returns the following error in the error_log:

/usr/local/apache/bin/httpd: error in loading shared libraries: /usr/local/apache/libexec/php3_vmailmgr
.so: undefined symbol: _vm_adduser

My php3.ini file has the following entries:

extension_dir   =       /usr/local/apache/libexec
extension = php3_vmailmgr.so

The code that causes the error is:

$vdomain = "tld.org";
$vpassword = "somepassword";
vm_adduser($vdomain,$vpassword,"username","foobar");


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:58 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 31 20:01:24 2020 UTC