php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24046 document_element() broken in 4.3.2
Submitted: 2003-06-05 11:46 UTC Modified: 2003-06-11 19:11 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: robert at entrinix dot com Assigned:
Status: No Feedback Package: DOM XML related
PHP Version: 4.3.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
16 - 7 = ?
Subscribe to this entry?

 
 [2003-06-05 11:46 UTC] robert at entrinix dot com
Using the following code in 4.3.0-4.3.1 works,

# Start reading the XML response.
$xml = domxml_open_mem($xml_response);
$root = $xml->document_element();

However, the *exact* same code, compiled with the exact same flags in 4.3.2 results in:

Fatal error: Call to a member function on a non-object in /data/websites/client on line 74, line 74 being:

"$root = $xml->document_element();"

Roll back to 4.3.1, and it works fine.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-06 00:53 UTC] sniper@php.net
Please provide a short but COMPLETE example script
which can be just copied and pasted from this report and run..

 [2003-06-11 19:11 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 09:01:27 2019 UTC