php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24042 pfpro support compile fails, reports incorrect pfpro version
Submitted: 2003-06-05 10:56 UTC Modified: 2004-01-20 16:20 UTC
From: age at salsashark dot net Assigned:
Status: Not a bug Package: Verisign Payflow Pro related
PHP Version: 4.3.2 OS: RedHat Linux 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: age at salsashark dot net
New email:
PHP Version: OS:

 

 [2003-06-05 10:56 UTC] age at salsashark dot net
PFpro libs are current, version 3.06. PHP compiled fine in RedHat 7.3. Same errors on another clean install of RH 9 with PHP 4.3.2 and 4.3.1.

> ./configure --with-pfpro=shared,/usr/local/lib

Fails, returns:

configure: error: The pfpro extension requires version 2 or 3 of the SDK


config.log:

configure:61887: checking for pfproInit in -lpfpro
configure:61906: gcc -o conftest -g -O2
    -L/usr/local/lib
    conftest.c -lpfpro  -lresolv -lm -ldl -lnsl  1>&5
/usr/local/lib/libpfpro.so: undefined reference to `__ctype_b'
/usr/local/lib/libpfpro.so: undefined reference to `__ctype_tolower'
collect2: ld returned 1 exit status
configure: failed program was:
#line 61895 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char pfproInit();

int main() {
pfproInit()
; return 0; }
configure:61939: checking for PNInit in -lpfpro
configure:61958: gcc -o conftest -g -O2
      -L/usr/local/lib
      conftest.c -lpfpro  -lresolv -lm -ldl -lnsl  1>&5
/usr/local/lib/libpfpro.so: undefined reference to `__ctype_b'
/usr/local/lib/libpfpro.so: undefined reference to `__ctype_tolower'
collect2: ld returned 1 exit status
configure: failed program was:
#line 61947 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char PNInit();
    
int main() {
PNInit()
; return 0; }

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-06 02:15 UTC] sniper@php.net
The pfpro libs are not compatible with RH9. (different glibc)
(and you should use --with-pfpro=shared,/usr/local too)

Not PHP bug.

 [2004-01-10 16:18 UTC] toddclark at trainorders dot com
I have Redhat 9 and I received the same error while installing php 4.3.4 with the pfpro flag.

So I went into the php museum and downloaded and installed 4.2.3 and all works great now.

As for sniper@php.net I don't know what you define as a bug, but I call anything that works in older versions, but broken in a more up to date version a bug.
 [2004-01-20 16:20 UTC] shiflett@php.net
For those who are receiving this error on Red Hat 9, you should contact Verisign for an SDK specifically for Red Hat 9.  At the time of this post, this is only possible if you call or email them:

888-883-9770 or vps-support@verisign.com
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 01:01:24 2020 UTC