php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24020 print/echo/heredoc randomly slows down
Submitted: 2003-06-04 11:07 UTC Modified: 2003-06-04 17:06 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: grandadmirale at yahoo dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.3.1 OS: Redhat linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: grandadmirale at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-06-04 11:07 UTC] grandadmirale at yahoo dot com
print/echo/heredocs will randomly slow down to an unacceptable time. I've timed just the print command itself, and it will be fine printing at 0.0000## seconds, and then randomly it will shoot up to anywhere from 0.01 seconds, to 0.2 seconds, which is unacceptable. The variation in html being printed is very slim, it is not printing a large ammount of html. I can't provide the script that has this problem publicly since it's a for-profit script, but if contacted by email I will provide all I can. The system stores all html in the database and queries for it when needed and prints it out, I've tried also storing it in a file, and even printing it out directly in the function without any middleman function with print, echo, and heredocs, nothing helps.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-04 14:44 UTC] elmicha@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

You don't have guaranteed response times in a multi-tasking environment. Even in single-user-mode you have kernel daemons like kupdated and bdflush that will slow down the system a bit now and then. And your database also isn't just sitting there, doing nothing. Unless you can come up with a _short_ example script that shows this "problem", this is bogus.
 [2003-06-04 17:03 UTC] grandadmirale at yahoo dot com
This isn't bogus, I can't provide a short script to reproduce it, I don't need help in using php, I've been using it for almost two years now. The database isn't the problem, it's queries run fine, the bug shows its face randomly but once it does, that same piece of html has a problem every time.
 [2003-06-04 17:06 UTC] grandadmirale at yahoo dot com
Here: http://xbb.agigames.com/proof.jpg
PTime is what your looking at, it consists of this:
$timeStart = getmicrotime();
print $html2;
$timeStop = getmicrotime();
It's ONLY the printing, as you can see it just goes along as it should and then randomly shoots up to 0.1 seconds. The rest are in the 0.0000# range.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 22:01:26 2020 UTC