php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23995 ftp_ssl_connect() function not defined
Submitted: 2003-06-03 12:37 UTC Modified: 2003-06-04 14:36 UTC
From: dstarr at allofe dot net Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.3.2 OS: Windows 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dstarr at allofe dot net
New email:
PHP Version: OS:

 

 [2003-06-03 12:37 UTC] dstarr at allofe dot net
I am using IIS 5 on Windows 2000. I am trying to use the ftp_ssl_connect() function, however I get Fatal error: Call to undefined function: ftp_ssl_connect().  I have OpenSSL enabled with OpenSSL Version 0.9.7b 10 Apr 2003.  This is how it appears in the phpinfo().  The openssl functions are available.  The only information I have found regarding this issue is located at http://us3.php.net/manual/en/function.ftp-ssl-connect.php and http://us3.php.net/manual/en/ref.openssl.php which I have followed.  Also, FTP support is enabled and Registered PHP Streams are php, http, ftp, compress.zlib.  Any help would be greatly appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-03 12:42 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

...
 [2003-06-03 16:40 UTC] edink@php.net
Download http://ftp.proventum.net/pub/php/win32/misc/openssl/php-4.3.2-ssl.zip and replace your php4ts.dll file to get ssl enabled distro.
 [2003-06-04 14:36 UTC] dstarr at allofe dot net
Thanks for the information on the php4ts.dll with the link.  That has enabled me to get one step further.  The function is now defined and can be called, however it won't connect, it just hangs.  I know the address I am using is correct because I can sftp from another linux box to it.  The code I am trying is:
$sftp = ftp_ssl_connect("192.168.1.40");
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 08 06:01:25 2020 UTC