php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23958 apache2handler should include output from `apr-config --includes`
Submitted: 2003-06-02 10:58 UTC Modified: 2003-06-02 11:02 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: dilinger at voxel dot net Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 4.3.2 OS: Debian unstable
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dilinger at voxel dot net
New email:
PHP Version: OS:

 

 [2003-06-02 10:58 UTC] dilinger at voxel dot net
Debian's apache2-dev and libapr0-dev packages put headers in different places; /usr/include/apache2 and /usr/include/apr-0,  respectively.  Unfortunately, apxs2 doesn't output the location of apr headers, which is required in order to compile.

So, compilation ends up failing w/:

/bin/sh /home/dilinger/php-4.3.2/libtool --silent --preserve-dup-deps --mode=compile /home/dilinger/php-4.3.2/meta_ccld  -Isapi/apache2handler/ -I/home/dilinger/php-4.3.2/sapi/apache2handler/ -DPHP_ATOM_INC -I/home/dilinger/php-4.3.2/include -I/home/dilinger/php-4.3.2/main -I/home/dilinger/php-4.3.2 -I/usr/include/apache2 -I/home/dilinger/php-4.3.2/Zend -I/usr/include/libxml2 -I/usr/include/mysql
-I/home/dilinger/php-4.3.2/ext/xml/expat  -D_REENTRANT -I/home/dilinger/php-4.3.2/TSRM  -g -O2 -pthread -DZTS  -prefer-pic -c /home/dilinger/php-4.3.2/sapi/apache2handler/sapi_apache2.c -o sapi/apache2handler/sapi_apache2.lo
/home/dilinger/php-4.3.2/sapi/apache2handler/sapi_apache2.c:38:25: apr_strings.h: No such file or directory


Here's the output of apr-config --includes:

 -I/usr/include/apr-0

This is something that the apache folks know about, but isn't likely to change anytime soon, due to the rather lame apxs interface they've standardized on.  So, it would be nice if php worked around this.

The simplest way to fix this is to add
  CPPFLAGS="$CPPFLAGS `apr-config --includes`"
to sapi/apache2handler/config.m4.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-02 11:02 UTC] sniper@php.net
We do not workaround bugs in 3rd party software, especially
when they're this obvious. 

And you can workaround this too
with using 'CFLAGS="-I/the/missing/path1 -I/the/missing/path2 ..etc.." ./configure ..your options..'

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 13:01:26 2019 UTC