php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23938 Memory leak?
Submitted: 2003-06-01 13:22 UTC Modified: 2003-06-01 20:42 UTC
From: bugs at ramihyn dot sytes dot net Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.3.2 OS: Windows 2000 SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs at ramihyn dot sytes dot net
New email:
PHP Version: OS:

 

 [2003-06-01 13:22 UTC] bugs at ramihyn dot sytes dot net
Hi,

i use a php script for file downloads on my webserver. Since I am using that script Apache's memory usage is constantly increasing. Apache crashes and restarts when no more memory is available. I'm not sure this is a PHP bug, it could also be an Apache bug.

Script source: http://h3km3k.ath.cx/~bugs/file.phps

Apache version used is: 2.0.45 (Win32)

I noticed that memory leak in the following PHP versions:
4.3.0
4.3.1
4.3.2RC1
4.3.2RC2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-01 20:42 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

There are already reports about memleaks under Apache2.
Search the bug db BEFORE you submit new reports.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 00:01:25 2020 UTC