php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23908 problem with PATH_INFO urls
Submitted: 2003-05-30 14:16 UTC Modified: 2003-06-02 14:06 UTC
From: pagameba at magma dot ca Assigned: shane (profile)
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.2 OS: winxp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pagameba at magma dot ca
New email:
PHP Version: OS:

 

 [2003-05-30 14:16 UTC] pagameba at magma dot ca
Not sure of the classification of this one, or even the summary at this point.  Pres2 uses PATH_INFO to calculate what presentation/slide to show with a URL something like:

http://myserver/pres2/show.php/mypresentation/1

This worked with PHP 4.3.2 RC1 but I just installed PHP 4.3.2 final and now I get "No input file specified.".

I've hacked pres2 to use query strings instead, which works fine.  Is this a configuration issue?  I changed nothing in my php.ini between rc1 and the final version.

Oh, and register_globals in On because pres2 needs it.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-01 20:40 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


.
 [2003-06-02 12:28 UTC] pagameba at magma dot ca
create a script called pathinfo.php at your web root with the following contents:

<? echo $_SERVER["PATH_INFO"]; ?>

and open this with

http://localhost/pathinfo.php/my/path

in PHP 4.3.2 RC1 (up to RC4 I think) this would result in a page containing:

my/path

with the release version of PHP 4.3.2, this returns:

No input file specified.

winxp, apache 1.3.26.  No changes to httpd.conf or php.ini between the RC and final.

I noticed also on the main php website,

http://www.php.net/in_array

this should search the documentation for in_array and redirect to the in_array page, but it returns an error.  I think this is caused by the same error.
 [2003-06-02 13:16 UTC] sniper@php.net
Does not work, seems like some late bugfix broke this then..


 [2003-06-02 14:06 UTC] shane@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

cgi.fix_pathinfo=1 in php.ini fixes this.  4.3.2 was changed to default to cgi.fix_pathinfo=0 as that fixes BC for the majority of apps that were written prior.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC