php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23850 Corrected error display for problems running APXS
Submitted: 2003-05-28 08:01 UTC Modified: 2003-05-28 09:12 UTC
From: B dot Candler at pobox dot com Assigned:
Status: Closed Package: Compile Warning
PHP Version: 4.3.1 OS: FreeBSD-4.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: B dot Candler at pobox dot com
New email:
PHP Version: OS:

 

 [2003-05-28 08:01 UTC] B dot Candler at pobox dot com
If there was a problem running APXS at configure time, it is re-run to generate a visible error message. However the script forgets to add the correct command-line parameters; as a result you always get the default APXS usage page instead of a report of what the error actually was.

The following patch fixes it:

--- php-4.3.1/sapi/apache/config.m4.orig        Thu Jul 25 19:37:16 2002
+++ php-4.3.1/sapi/apache/config.m4     Wed May 28 13:51:44 2003
@@ -26,7 +26,7 @@
     AC_MSG_RESULT([2.  Apache was not compiled with DSO support (--enable-module=so);])
     AC_MSG_RESULT([3.  'apxs' is not in your path.  Try to use --with-apxs=/path/to/apxs])
     AC_MSG_RESULT([The output of $APXS follows])
-    $APXS
+    $APXS -q CFLAGS
     AC_MSG_ERROR([Aborting]) 
   fi 

Without this patch, all you see is:
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...

which is not very helpful.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-28 09:12 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Oct 01 20:05:53 2022 UTC