php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #23795 .chm's <pre> tags in examples WERE displayed as one line
Submitted: 2003-05-24 17:57 UTC Modified: 2003-05-28 18:08 UTC
From: akos987 at cs dot elte dot hu Assigned: derick (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 4.3.1 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akos987 at cs dot elte dot hu
New email:
PHP Version: OS:

 

 [2003-05-24 17:57 UTC] akos987 at cs dot elte dot hu
It seems to me that the .chm version of the documentation
I could download from php.net (Hungarian language; I can't check for some sort of explicit version as right now your server refuses connection, so here's the date: it was downloaded on 05/23/2003) has the following problem:

Any page where the source had examples and hence lenghty text within a <pre> </pre> element fails to be broken into several lines. The source extracted by Explorer's right-click feature doesn't have any line breaking characters. I suspect this error is due to the Unix/Windows line termination difference and Microsoft HTML Help Workshop would probably prefer the Windows style. 

The main issue is that the pages involved get the width of the <pre> </pre> element when displayed or printed, which renders them practically unreadable as all lines extend to several screen's width.

I hope it wasn't me messing up something and taking your time for vain.

Thanks for being there.

  Akos Groller

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-25 04:36 UTC] goba@php.net
Assigning to Derick
 [2003-05-25 04:48 UTC] derick@php.net
That's the meaing of PRE, do not break lines. Not a bug -> bogus
 [2003-05-25 05:01 UTC] goba@php.net
If I read correctly, Akos says that all the examples display on one line instead of multiple lines, which are intended to. That seems to be a bug for me... Derick?
 [2003-05-25 05:07 UTC] derick@php.net
They definitely don't. Atleast I couldnt find that anywhere in the .hu manual.
 [2003-05-28 07:07 UTC] akos987 at cs dot elte dot hu
The pre-05/23/2003 version -- I insist -- had the problem,
but the HU .chm has already been rebuilt (and so has the EN one), the current version(s) is (are) OK.

Bogus -> closed, I prefer.
(Or you should add a `temporal discrepancy in the space-time continuum' category, which might not be your intention...)

  Akos
 [2003-05-28 07:22 UTC] derick@php.net
Keep it bogus, there were no changes at all.
 [2003-05-28 18:08 UTC] akos987 at cs dot elte dot hu
Any insectologist daring to face the fearful may arrange the encounter at 

http://chardonnay.math.bme.hu/~akos987/php_manual_hu.chm,

in the now-out-of-date Hungarian php manual.
(This is a limited-time offer as I don't have any amount of webspace. No application fee, however, especially as the Open Publication License v1.0 is kept in sight;-)

I know the particular being is dead, but refuse to consider it never-existent. (That's the meaning of closed, not to
completely forget about past errors, though fixed they are.)
Yet if the creature eventually COULD fly out somehow -
and it did so and right at the php.net/download-docs page -,
one might feel quite embarrassed not to know of any particular reason that killed (or at least dewinged) it.

The scientific classification may remain bogus for ever, but then I hope not having any ``bogus'' of that size beneath my favourite wardrobe. Not even dead, closed, killed, extinct.

  Akos
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jun 24 10:01:23 2021 UTC