php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23660 variable assignment by url doesn't seem to work
Submitted: 2003-05-16 12:07 UTC Modified: 2003-05-16 12:35 UTC
From: mo dot linux at web dot de Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.3.1 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mo dot linux at web dot de
New email:
PHP Version: OS:

 

 [2003-05-16 12:07 UTC] mo dot linux at web dot de
i am using php 4.3.1 with apache 1.3.27-r3

i opened the following adress in the brower:
http://localhost/test.php?a=a

thats in the script test.php:
if(isset($a)) echo "\$a is set";
else echo "\$a is not set";

the output:
$a is not set

looks like a bug.. or what did i wrong?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-16 12:35 UTC] derick@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.

...
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 14:01:28 2024 UTC