php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23646 different timezone for different timestamps
Submitted: 2003-05-15 14:30 UTC Modified: 2003-05-15 14:52 UTC
From: p dot vukadinov at bers-soft dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.3.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: p dot vukadinov at bers-soft dot com
New email:
PHP Version: OS:

 

 [2003-05-15 14:30 UTC] p dot vukadinov at bers-soft dot com
My system is:
PHP 4.3.1
Apache 1.3.27
on Linux box (kernel 2.4.20) with glibc 2.3.1

When i use date('T') with different timestmas i get different results

date('T m.d.Y',307573767) - 01.10.1979 EEST
date('T m.d.Y',307577835) - 01.10.1979 EET

date from BASH console returns EEST

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-15 14:52 UTC] derick@php.net
We are happy to tell you that you just discovered Daylight Savings
Time. For more information see:
http://webexhibits.org/daylightsaving/b.html
Instead of using mktime/date consider using gmmktime and gmdate which do
not suffer from DST.

EET  Eastern Europe Time        UTC+2 hours Athens during winter
EEST Eastern Europe Summer Time UTC+3 hours Athens during summer

(from http://www.timeanddate.com/time/abbreviations.html)
 [2003-05-17 13:52 UTC] langdraad at hotmail dot com
Is this a confirmed problem? I have the same thing. When i refresh a page it gives GMT CEST or GMT-1. Whatever it likes. There seems to be no logic. A test example is at http://dave.puxie.nl/timetest

php version 4.3.1
apache 2.0
gentoo linux
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 29 08:01:32 2024 UTC