php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2363 MIME-Parser even more broken. :)
Submitted: 1999-09-23 06:18 UTC Modified: 2002-06-16 08:58 UTC
From: ash at ash dot de Assigned:
Status: Not a bug Package: Parser error
PHP Version: 3.0.12 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ash at ash dot de
New email:
PHP Version: OS:

 

 [1999-09-23 06:18 UTC] ash at ash dot de
PHP only expects more than one MIME-Header-Lines if there is a "filename" in the Content-Disposition and so returns every value with some
whitespace prepended to it. (seems to be the \n but i haven't
checked. but, what else should it be ?)
all my tries to hack a generic "move on
till you find the "end of headers"-empty-line" failed ... (mainly
because my C-Knowledge is a bit unpracticed ....)

would be nice if you could try to fix this because "PHP is not
lynx-compatible" sucks. and i dont want to convert to using
perl-CGIs instead of PHP just because of this problem ... :(

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:58 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu May 23 10:01:29 2019 UTC