php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23621 PHP 4.3.2 and JpGraph 1.12.1: "JpGraph Error: Unknown gradient style (=0
Submitted: 2003-05-13 23:38 UTC Modified: 2003-05-17 05:22 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: ggerardo at hotmail dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.3.2RC2 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ggerardo at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-05-13 23:38 UTC] ggerardo at hotmail dot com
It seems to be that the GD2 extensions is not working correctly at this version.
When I use Jpgraph with PHP 4.3.1 works ok.

More Info:
http://www.aditus.nu/bugtraq/bug.php?op=print&bugid=114

Testing Enviroment Settings:
- Windows XP SP1 Professional
- IIS 5.1
- Jpgraph 1.12.1

Extensions enabled:
- php_gd2.dll
- php_gettext.dll

Error Message:
JpGraph Error: Unknown gradient style (=0).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-14 21:06 UTC] iliaa@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2003-05-16 19:22 UTC] jpgraph at aditus dot nu
The problem seems to be that in 4.3.2RC2 there where a problem with class instance variabel initialization. Basically initialization with negative values did not work which caused JpGraph to fail.

For example

class SomeClassName {

  var $a = -1;

...

}

did not properly initialize $a.
This seems to have been fixed in RC3
 [2003-05-16 20:24 UTC] ggerardo at hotmail dot com
Thanxs a lot !!! 
:)

GeRaRDo
 [2003-05-17 05:22 UTC] derick@php.net
closing then
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 02:05:45 2022 UTC