php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #236 wrong parameters order for Digital's cc
Submitted: 1998-04-03 06:13 UTC Modified: 1998-04-08 22:44 UTC
From: Vladimir Litovka <doka at webest dot com> Assigned:
Status: Closed Package: Compile Warning
PHP Version: 3.0 Release Candidate 3 OS: Digital Unix v4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: Vladimir Litovka <doka at webest dot com>
New email:
PHP Version: OS:

 

 [1998-04-03 06:13 UTC] Vladimir Litovka <doka at webest dot com>
There is problem with Digital's cc/ld, which doesn't
understand this combination of command line parameters:

  cc $CFLAGS $LDFLAGS $LIBS -o conftest conftest.c

for example:
  cc ... -o conftest -lpq conftest.c
in such cases it reports about unresolved symbols, that
really is in library.

You need to change configure due to this feature.

This error appears, for example, when configure checks
for PQcmdTuples, where you are using
  LDFLAGS="$LDFLAGS $PGSQL_FLAGS $PGSQL_LIBS"
but really need
  LDFLAGS="$LDFLAGS $PGSQL_FLAGS"
  LIBS="$LIBS $PGSQL_LIBS"
with all subsequent changes (save/restore old_LIBS)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-04-08 22:44 UTC] jim
Fixed in the latest CVS.

Patch also available at: http://ca.php.net/cvsweb.cgi/configure.in.diff?r1=1.180&r2=1.181
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Feb 17 09:01:24 2019 UTC