php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23586 _emalloc Segmentation fault
Submitted: 2003-05-11 18:05 UTC Modified: 2003-05-18 11:54 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: x4com at web dot de Assigned:
Status: No Feedback Package: Scripting Engine problem
PHP Version: 4.3.1 OS: Debian Linux/GNU 3.0r1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: x4com at web dot de
New email:
PHP Version: OS:

 

 [2003-05-11 18:05 UTC] x4com at web dot de
Hello,

i test just the examples/tabletest.php from pc4p and i get this error back:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 8236)]
0x08210d06 in _emalloc (size=129, __zend_filename=0x8373f80 "/usr/local/src/apache_src/php-4.3.1/main/spprintf.c",
    __zend_lineno=143, __zend_orig_filename=0x0, __zend_orig_lineno=0)
    at /usr/local/src/apache_src/php-4.3.1/Zend/zend_alloc.c:123
123     {

have you a idea?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-11 18:13 UTC] x4com at web dot de
and i get this error back:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 8419)]
0x0814158f in zif_pdf_open_memory_image (ht=2, return_value=0x8b90c7c, this_ptr=0x0, return_value_used=1)
    at /usr/local/src/apache_src/php-4.3.1/ext/pdf/pdf.c:1982
1982                                            color = im->pixels[im->sy][im->sx];
 [2003-05-12 01:21 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2003-05-12 12:35 UTC] x4com at web dot de
what do you want to still know?
sorry I do not understand you
 [2003-05-13 18:08 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

And if this happens with the snapshot, give us a short example script which we can use to reproduce this too.
(this is likely to be fixed already)

 [2003-05-18 11:54 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 02:05:48 2023 UTC