php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23562 Unable to complete network request to host "localhost". Failed to locate host m
Submitted: 2003-05-09 06:33 UTC Modified: 2003-05-09 06:37 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: rcpku at poczta dot onet dot pl Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 4.3.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 + 36 = ?
Subscribe to this entry?

 
 [2003-05-09 06:33 UTC] rcpku at poczta dot onet dot pl
PHP 4.3.1 is running on linux Redhat 6.2 /with many manual updates/ + Apache 2.0.45 and trying to connect to interbase database.
All scripts are working ok from command-line, 
like: "php page.php" while I am getting error like in subject if connection to ibase is being made from script runing via Apache.
Interbase clent and server works OK, 'services' file includes proper line:
gds_db        3050/tcp  

So all is working but not visa Apache!
Paul


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-09 06:35 UTC] rcpku at poczta dot onet dot pl
Here is a full error text /it's well known/

Unable to complete network request to host "localhost". Failed to locate host machine. Undefined service gds_db/tcp. 

Paul
 [2003-05-09 06:37 UTC] gschlossnagle@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Local networking issue, this is not a bug in PHP, but 
improper system configuration.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 16:01:25 2020 UTC