php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23561 Web Server is slowed - and die
Submitted: 2003-05-09 05:44 UTC Modified: 2003-05-09 06:00 UTC
From: kepesk at peto dot hu Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.3.1 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kepesk at peto dot hu
New email:
PHP Version: OS:

 

 [2003-05-09 05:44 UTC] kepesk at peto dot hu
Hi !

The problem is that:
System is Apache 1.3.27/and Sambar 5.1-5.3 MySQL3.23.47.
Windows XP.
The web site is working, it is uses pconnect.

When the site are used by more users, and it get more query,
then the server loading on 95-100% CPU time.
This hanging is not ended, and when it have 100% of CPU time, the server have been crashed.

We cannot understand it. The php codes are very simple.
When we look the netstat, we are see, that the mysql open new pconnection for every request, but cannot reused or destroy them.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-09 06:00 UTC] sniper@php.net
We are aware of PHP's problems with stability under IIS and are working 
to rectify the problem. Unfortunatly your bug report does not contain any
extra useful information and we already have enough bug reports open about
this issue. If you can provide more detailed information such as a 
reproducable crash or a backtrace please do so and reopen this bug. 
Otherwise please keep trying new releases as we are working to resolve 
the problems on this platform
 
Thanks for your interest in PHP.

Expected behaviour..
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue May 18 18:01:23 2021 UTC