php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23560 XML_Tree -> Call to undefined function: get_node_by_path()
Submitted: 2003-05-09 05:31 UTC Modified: 2003-07-10 06:25 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: stefan dot textor at dsi-project dot de Assigned: cox (profile)
Status: Closed Package: PEAR related
PHP Version: 4.3.1 OS: windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: stefan dot textor at dsi-project dot de
New email:
PHP Version: OS:

 

 [2003-05-09 05:31 UTC] stefan dot textor at dsi-project dot de
I have tested the following Script with XML_Tree:

 require_once 'XML/tree.php';
    $tree  = new XML_Tree;
    $root =& $tree->addRoot('root');
    $foo  =& $root->addChild('foo');
    $test = $tree->insertChild('root',0,'test','bla');
    header('Content-Type: text/xml');
    $tree->dump();

resulting in:

Fatal error: Call to undefined function: get_node_by_path() in C:\php4\pear\XML\tree.php on line 138

I used v 1.1 of XML_Tree on PEAR 1.1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-09 07:01 UTC] arnaud@php.net
Indeed.

I had a wuick look at the code but it goes beyond my comprehension of the package atm. Does somebody feel comfortable enough with this ?
 [2003-05-20 08:32 UTC] arnaud@php.net
I had a deeper look today. The inserChild method was added a long time ago and my guess is that it has never been properly tested. Browsing the cvs history i did not see any get_node_by_path method. Inclunding the time when the insertChild method was added.

If anybody feels up to the challenge please give it a try. I don't properly understand the class well enough to fix it.
 [2003-06-29 05:59 UTC] rene at reneschmidt dot de
Wasn't PEAR supposed to include only well-tested and 
well-written code? How comes this issue hasn't been sorted 
out yet... Makes my angry because now I'm stuck because of 
this bug and I have to work around it. I'll let you know 
if I was successful... 
 
screne
 [2003-07-10 06:25 UTC] cox@php.net
Fixed in CVS. Please try it.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 20:03:34 2021 UTC