php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23516 pear registry crached after usage of pear_frontend_Web
Submitted: 2003-05-06 18:56 UTC Modified: 2003-05-27 18:59 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: stefan dot textor at dsi-project dot de Assigned: pajoye (profile)
Status: Closed Package: PEAR related
PHP Version: 4.3.1 OS: windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 - 34 = ?
Subscribe to this entry?

 
 [2003-05-06 18:56 UTC] stefan dot textor at dsi-project dot de
after problemless usage of pear_frontend_Web, i had a few days ago a growing problem with the pear registry:
function.unserialize: corruption at offset [bla]

i have tested this with the latest packages on pear 1.01 and pear 1.1 and was able to reproduce it.

in my opinion it must be a sideeffect of a package released in the last 7 days used by pear installer directly. in the old installation (pear 1.01) i had all stable packages installed and the error should have occured during an upgrade. in the new installation (pear 1.1 out of php 4.3.2rc2 zip package)
i had only the basically installed packages and the packages needed for pear_frontend_web. after installation of one or two packages (starting topdown the list) the error occured again. 
the error is only shown in the comandline installer. the webinstaller does not seem to remark the corrupted registry.

sorry for my bad english :(

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-10 15:09 UTC] pajoye@php.net
Hello,

Can you paste here the errors printed by the installer?

and try with the latest php snapshots (PEAR, 4.3.1 works well with PEAR 1.1)?

thank's for your report

pierre
 [2003-05-24 10:38 UTC] pajoye@php.net
Hello,

Can you try with latest php snapshot?
I suspect that may come from a serialize problem.

pierre
 [2003-05-26 20:42 UTC] pear dot php dot net at e1da dot net
C:\php4>pear list

Notice: unserialize(): Error at offset 760 of 1363 bytes in Registry.php on line
327

Error relates to unserialize() of "Var_Dump.reg";
offset 760 is around;
s:11:"description";s:360:"Displays informations  about the
...
are printed.";s:11:"maintainers";
            ^here

I count 364 characters for this string.
There are 4 lines in this string
it includes 4 0x0d0x0A pairs
The .reg files created by cli pear install have 0x0a for line feeds.
Is there something wrong with the way the web interface serializes line feeds?

Regards
Andrew Braund

PS I can fix the registry by uninstalling the package using the web interface than installing it again using cli.
 [2003-05-27 18:59 UTC] pajoye@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Fixed right now in cvs.
A release follows.

thank's for the report,

pierre
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 08:03:34 2021 UTC