php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23495 PHP CGI binary dumps core
Submitted: 2003-05-05 12:17 UTC Modified: 2003-05-05 23:13 UTC
From: dave at socrates dot thinkhost dot com Assigned:
Status: Not a bug Package: CGI/CLI related
PHP Version: 4.3.2RC2 OS: FreeBSD 4.8-STABLE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dave at socrates dot thinkhost dot com
New email:
PHP Version: OS:

 

 [2003-05-05 12:17 UTC] dave at socrates dot thinkhost dot com
GNU gdb 4.18 (FreeBSD)
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-freebsd"...Deprecated bfd_read called at /usr/src/gnu/usr.bin/binutils/gdb/../../../../contrib/gdb/gdb/dbxread.c line 2627 in elfstab_build_psymtabs
Deprecated bfd_read called at /usr/src/gnu/usr.bin/binutils/gdb/../../../../contrib/gdb/gdb/dbxread.c line 933 in fill_symbuf

Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libcrypt.so.2...done.
Reading symbols from /usr/local/lib/libmcal.so...done.
Reading symbols from /usr/local/lib/libc-client4.so.8...done.
Reading symbols from /usr/local/lib/libexpat.so.4...done.
Reading symbols from /usr/local/lib/libpq.so.2...done.
Reading symbols from /usr/local/lib/libpdf.so.4...done.
Reading symbols from /usr/lib/libz.so.2...done.
Reading symbols from /usr/local/lib/libtiff.so.4...done.
Reading symbols from /usr/local/lib/libpng.so.5...done.
Reading symbols from /usr/local/lib/libjpeg.so.9...done.
Reading symbols from /usr/local/lib/mysql/libmysqlclient.so.10...done.
Reading symbols from /usr/local/lib/libming.so.3...done.
Reading symbols from /usr/lib/libm.so.2...done.
Reading symbols from /usr/local/lib/libmhash.so.2...done.
Reading symbols from /usr/local/lib/libmcrypt.so.8...done.
Reading symbols from /usr/local/lib/libltdl.so.1...done.
Reading symbols from /usr/local/lib/libldap.so.2...done.
Reading symbols from /usr/local/lib/liblber.so.2...done.
Reading symbols from /usr/lib/libpam.so.1...done.
Reading symbols from /usr/local/lib/libintl.so.4...done.
Reading symbols from /usr/local/lib/libgd.so.2...done.
Reading symbols from /usr/local/lib/libfreetype.so.9...done.
Reading symbols from /usr/local/lib/libcurl.so.2...done.
Reading symbols from /usr/local/lib/libxml2.so.5...done.
Reading symbols from /usr/local/lib/libiconv.so.3...done.
Reading symbols from /usr/lib/libc.so.4...done.
Reading symbols from /usr/lib/libssl.so.3...done.
Reading symbols from /usr/lib/libcrypto.so.3...done.
Reading symbols from /usr/local/lib/libssl.so.3...done.
Reading symbols from /usr/local/lib/libcrypto.so.3...done.
Reading symbols from /usr/local/lib/libssl.so.4...done.
Reading symbols from /usr/local/lib/libcrypto.so.4...done.
Reading symbols from /usr/local/Zend/lib/ZendOptimizer.so...done.
Reading symbols from /usr/libexec/ld-elf.so.1...done.
#0  0x81901de in _estrdup (s=0x0) at /usr/local/src/php-4.3.2RC2/Zend/zend_alloc.c:363
363             length = strlen(s)+1;
(gdb) bt
#0  0x81901de in _estrdup (s=0x0) at /usr/local/src/php-4.3.2RC2/Zend/zend_alloc.c:363
#1  0x81b24e5 in init_request_info () at /usr/local/src/php-4.3.2RC2/sapi/cgi/cgi_main.c:709
#2  0x81b2b57 in main (argc=30, argv=0xbfbff5ec) at /usr/local/src/php-4.3.2RC2/sapi/cgi/cgi_main.c:1238
#3  0x808cb56 in _start ()
(gdb) quit

This is from a PHP binary built with the 4.3.2RC2 source. I have created a working CGI binary by rolling back to the 4.3.1 source. This problem seems to be new in 4.3.2 thread.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-05 14:19 UTC] magnus@php.net
Remove Zend Optimizer.. 
Does that solve it ? 
 [2003-05-05 21:22 UTC] dave at socrates dot thinkhost dot com
Nope, I have commented out the Zend Optimizer lines in the PHP CGI php.ini, it makes no difference. Note that I have also tried building a basic PHP CGI binary (./configure --disable-all)

This problem is the same problem as bug report #23196 (which was never solved, and started with the PHP-4.3.2RC1 source tree)
 [2003-05-05 23:13 UTC] magnus@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

ok then.. Add your comments to #23196 . 
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC