php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23472 ftp_site() does reply only false/true
Submitted: 2003-05-03 17:58 UTC Modified: 2003-05-03 22:45 UTC
From: marxim at mail dot ee Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marxim at mail dot ee
New email:
PHP Version: OS:

 

 [2003-05-03 17:58 UTC] marxim at mail dot ee
ftp_site() does only reply false/true, but not what it gets from server. Also, ftp_raw() function does not exist. So, is any way to get some information from ftp server if i type some raw commands?

Grz.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-03 18:15 UTC] derick@php.net
ftp_raw() is added, but only in CVS (see http://www.php.net/manual/en/function.ftp-raw.php) and the documentation for ftp_site() says this:

bool ftp_site ( resource ftp_stream, string cmd)

ftp_site() sends the command specified by cmd to the FTP server. SITE commands are not standardized, and vary from server to server. They are useful for handling such things as file permissions and group membership.

Returns TRUE on success or FALSE on failure. 

Not a bug -> bogus
 [2003-05-03 18:27 UTC] marxim at mail dot ee
Then again, my question was: how can get output from raw commands or how can i execute/run raw commands? There isnt any function what does the job :(
 [2003-05-03 22:45 UTC] pollita@php.net
*UN*officially, it will *PROBABLY* work to take the ext/ftp directory from a PHP5 snapshot (http://snaps.php.net) and copy it over the ext/ftp directory in your PHP4.3 tarball.

Do this *AT YOUR OWN RISK*.  Code in PHP5 has not passed quality assurance standards and mixing code between branches is neither tested nor officially supported.  There are many extensions in which this will certainly not work, but for the ftp extension you will probably be okay.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC