php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23425 Apache freezes when two requests come at the same time
Submitted: 2003-04-30 03:14 UTC Modified: 2003-05-05 09:20 UTC
From: jmiskei at itsys dot cz Assigned:
Status: Closed Package: InterBase related
PHP Version: 4CVS-2003-04-30 (stable) OS: Windows XP & NT 5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jmiskei at itsys dot cz
New email:
PHP Version: OS:

 

 [2003-04-30 03:14 UTC] jmiskei at itsys dot cz
I use latest stable version of PHP with Apache 2.0.45 and with InterBase extension. I use the module for apache (php4apache2.dll).
My problem is, that the Apache completely freezes when two requests (from two computers) come at the same time.
This problem occurs almost always when the two users request any script which connects to InterBase.
Then I always must restart Apache.

I am not sure whether this is problem of PHP or Interbase extension or Apache.

The same problem occurs with Apache 1.3.4 and 2.0.45 and on Windows XP and NT 5.0

I will appreciate any help
Thank you

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-30 09:49 UTC] moriyoshi@php.net
Did you try the cgi version as well? If the problem can be reproduced with that, it's likely an interbase problem, or possibly caused by a bug in your script.

 [2003-05-05 09:20 UTC] jmiskei at itsys dot cz
Now I have tried the CGI version of PHP and it seems to be OK.

Thank you for your help.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jun 25 20:05:44 2022 UTC