php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23416 configure not knowing apache version
Submitted: 2003-04-29 13:24 UTC Modified: 2003-05-01 19:17 UTC
Votes:4
Avg. Score:3.8 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: philip at cornado dot com Assigned:
Status: Wont fix Package: Apache2 related
PHP Version: 4.3.2RC2 OS: Mandrake
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: philip at cornado dot com
New email:
PHP Version: OS:

 

 [2003-04-29 13:24 UTC] philip at cornado dot com
Hello!  Compiling PHP with Apache2 support (with apache2handler) has one issue, here's my configure line:

./configure --with-apxs2=/usr/sbin/apxs2 --enable-sockets --enable-ftp --enable-cli --disable-cgi --enable-debug

Here are some of the results during configure:

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 2.0 module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... expr: non-numeric argument
./configure: line 3885: test: : integer expression expected
./configure: line 3887: test: : integer expression expected
yes

[snip]
checking for chosen SAPI module... apache2handler

Here are lines 3883 - 3889 of configure (formatted to fit nicely in this report):

  APACHE_VERSION=`expr $4 \* 1000000 + $5 \* 1000 + $6`

  if test "$APACHE_VERSION" -le 2000000; then
    { echo "configure: error: You have enabled Apache 2
            support while your server is Apache 1.3.  
            Please use the appropiate switch --with-apxs
            (without the 2)" 1>&2; exit 1;$
  elif test "$APACHE_VERSION" -lt 2000044; then
    { echo "configure: error: Please note that Apache 
            version >= 2.0.44 is required." 1>&2; exit 1; }
  fi


$APACHE_VERSION has no value, I tested it by echoing it in configure.  This APACHE_VERSION check only fails if a known  version is less than 2.0.44 so if it doesn't know the version at all (in my case) it will always pass.  But I happen to have 2.0.45 so it's not a problem, for me.

I have no clue why it can't figure out the APACHE_VERSION nor do I know this topic at all.  If feedback is required let me know :)  BTW, it compiled fine, make install worked perfectly.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-30 05:46 UTC] sniper@php.net
What do these commands output:

# /usr/sbin/httpd -v
# /usr/sbin/apxs2 -q SBINDIR
# /usr/sbin/apxs2 -q TARGET


 [2003-04-30 09:20 UTC] philip@php.net
[root@localhost tmp]# /usr/sbin/httpd -v
bash: /usr/sbin/httpd: No such file or directory

[root@localhost tmp]# /usr/sbin/httpd2 -v
Server version: Apache-AdvancedExtranetServer/2.0.45
Server built:   Apr 17 2003 15:33:43

[root@localhost tmp]# /usr/sbin/apxs2 -q SBINDIR
/usr/sbin

[root@localhost tmp]# /usr/sbin/apxs2 -q TARGET
httpd2

Note: Apache2 is installed from the official mdk RPM's.
 [2003-05-01 19:17 UTC] sniper@php.net
why the hell did they have to change that text??
Anyway: Won't fix.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 20 16:01:26 2019 UTC