php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23413 pear installation problem
Submitted: 2003-04-29 10:52 UTC Modified: 2004-03-29 23:59 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: marco dot busarello at bluemail dot ch Assigned: pajoye (profile)
Status: Not a bug Package: PEAR related
PHP Version: 4.3.2RC1 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marco dot busarello at bluemail dot ch
New email:
PHP Version: OS:

 

 [2003-04-29 10:52 UTC] marco dot busarello at bluemail dot ch
Hello

i recently tried to install the Pear Package Manager on my 
system. For this i made a new directory named 'pear' in my htdocs folder in wich i puted the 'go-pear.php'. when i now start the installation calling the file on my localhost it stopps at 70% because of the following errors:

> Starting installation ...
> Loading zlib: ok
> Downloading package: PEAR.............ok
> Downloading package: Archive_Tar......ok
> Downloading package: Console_Getopt....ok
> Downloading package: XML_RPC..........ok
> Downloading package: Pager............ok
> Downloading package: HTML_Template_IT....ok
> Downloading package: Net_UserAgent_Detect....ok
> Downloading package: PEAR_Frontend_Web....ok
> Bootstrapping: PEAR...................(remote)
> 
> Parse error: parse error in C:
> \WINNT\Profiles\srzxn0\LOCALS~1\Temp\gop3.tmp\PEAR.php on line 1
> 
> ok
> Bootstrapping: Archive_Tar............(remote) ok
> Bootstrapping: Console_Getopt.........(remote) ok
> Downloading package: DB...............ok
> Downloading package: Net_Socket.......ok
> Downloading package: Net_SMTP.........ok
> Downloading package: Mail.............ok
> Downloading package: XML_Parser.......ok
> Downloading package: phpUnit..........ok
> 
> Fatal error: Undefined class name 'pear' in C:
> \wampp2\htdocs\pear\go-pear.php on line 654

i got the file from 'http://go-pear.net'.

can you help me concerning this?

thank you very much
greetings
Marco Busarello


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-10 09:40 UTC] pajoye@php.net
Hello,

Can you try with the latest php snapshots?

pierre
 [2004-03-29 23:59 UTC] neufeind@php.net
Too long no feedback.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 14:01:28 2020 UTC