|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23367 Problems with loading every extension in the extensions dir
Submitted: 2003-04-26 18:20 UTC Modified: 2003-04-28 18:52 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: Sebastian dot Hippler at t-online dot de Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.3.1 OS: Windows XP Pro SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
27 - 11 = ?
Subscribe to this entry?

 [2003-04-26 18:20 UTC] Sebastian dot Hippler at t-online dot de
HTTP Server = IIS 5.1 over ISAPI

the Problem is that every try to load any extension of the extensions dir returns a messagebox what says "Unknown(); Unable to load the dynamical library "C:\PHP\extensions\php_pdf.dll" - the module wasn't found
but the path is correct and everything is right (even case sensitivity)


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-26 18:36 UTC]
You probably didn't copy the .dll's from the dll folder to somewhere in your path. It works fine for me, not a bug -> bogus.

 [2003-04-28 07:15 UTC] kylotan at hotmail dot com
I've made sure all the dlls were installed in the prescribed places (in my case, php_mcrypt.dll in c:\php\extensions, and libmcrypt.dll in winnt/system32), updated php.ini to point at the correct extensions directory, and I get this message:

PHP Warning: Unable to load dynamic library 'c:/php/extensions/php_mcrypt.dll'

Yet that file is confirmed as existing. Even if I have made some error elsewhere in the setup, that warning message is either wrong or insufficient.
 [2003-04-28 07:40 UTC]
How does the line in php.ini look like, and are you sure all .dlls have permissions to being executed/read by the Webserver User? (No idea how exactly this works in Windows)
 [2003-04-28 08:24 UTC] Kylotan at hotmail dot com
; Directory in which the loadable extensions (modules) reside.
extension_dir = C:/PHP/extensions


(all other extensions are commented out)

I explicitly set the permissions for 'everyone' to 'full control' on the dlls. Still no luck.
 [2003-04-28 09:06 UTC]
You probably missed the bit in the manual ( about downloading binary version of mcrypt library from
 [2003-04-28 09:10 UTC] Sebastian dot Hippler at t-online dot de
the whole directory including the extensions got read and  execute permission for the IUSR-Account. This Account is the Account twhat the Webserver is using
 [2003-04-28 09:11 UTC] kylotan at hotmail dot com
No, but you probably missed the bit in my comment above that reads, "I've made sure all the dlls were installed in the prescribed places (in my case, php_mcrypt.dll in c:\php\extensions, and libmcrypt.dll in winnt/system32)".
 [2003-04-28 09:29 UTC]
I just re-tested using latest stable cvs snapshot from and all 3 tested web servers (Apache, Apache2 and IIS) have no problems loading php with mcrypt so it must be some local configuration issue on your end.
 [2003-04-28 18:52 UTC] Sebastian dot Hippler at t-online dot de
i tried both msql (mysql.dll and mssql.dll) dlls and i also tried the pdf dll - without success
 [2003-05-08 10:25 UTC] demze at hotmail dot com
Got a pretty similar problem witj loading some extensions on win XP...

Some works (cpdf.dll, gd.dll for instance) but some others refuse to load. Quite usefull extensions like sablotron or xslt or domxml... every time i get the "cannot load module/procedure not found or module not found" message... I got it bad... I am going really mad at this... I need to run xsl transformation... Is there any other way to do it... I mean whitout xslt.dll or sablotron???


 [2003-12-04 09:07 UTC] markbitz at hotmail dot com
I was also getting the error message 

"Unknown(); Unable to load the dynamic library "C:\PHP\extensions\php_pdf.dll" - the module wasn't

on winXP. I ended up copying all the .dll's from both the extensions and dlls sub-dirs to my c:\windows\system32 subdirectory and it works fine now for me. A very frustrating problem. It must be something with the XP environment path space as I did not have to do this on my windows 2k box or 98 box.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 01:01:31 2024 UTC