php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23358 Error loading MailServerX
Submitted: 2003-04-26 03:16 UTC Modified: 2003-05-03 08:02 UTC
From: alex at aabrothers dot com dot au Assigned: phanto (profile)
Status: Not a bug Package: COM related
PHP Version: 4.3.2 RC OS: WinXP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
40 - 26 = ?
Subscribe to this entry?

 
 [2003-04-26 03:16 UTC] alex at aabrothers dot com dot au
MailServerX is an ActiveX Control by www.argosoft.com, I tested it in VB, VBS and ASP and it's working.
I tested it with PHP on IIS and Apache and both server terminate the PHP execution suddenly.

the code I?m using is...
$users = new COM('MailServerX.Users');

I?m expecting to get to the next line but execution terminates immediately

Please note that to get MailServerX working on a web server you need to also create a file 'mlsrv.ini' on the root of c drive with the following content...

[Setup]
Program Path = F:\Program Files\ArGo Software Design\Mail Server\
Users Path = F:\Program Files\ArGo Software Design\Mail Server\
Message Size Limit = 5
Case Sensitive Filters = 1
Scan Bodies = 0

This problem is because the ActiveX is not able to read the registry and get the values from there.

Please note that other ActiveX Controls are working with my configuration as it is. Eg. Word, Excel

The Event error is as follows...
Faulting application php.exe, version 4.3.1.1, faulting module php4ts.dll, version 4.3.1.1, fault address 0x00030727.

Thanks for your time.

Alex

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-26 23:25 UTC] alex at aabrothers dot com dot au
Version 4.3.2 from http://snaps.php.net/win32/php4-win32-STABLE-latest.zip Did not fix the problem... :( 

Since Feb no updates on COM has been dome.
 [2003-04-27 00:07 UTC] magnus@php.net
Version update. Assigning phanto.. 
 [2003-05-03 08:02 UTC] phanto@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

did you replace the php4ts.dll ?
it doesn't crash here.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 03:03:42 2022 UTC