php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23323 "mysql_pconnect(): Link to server lost, unable to reconnect" error
Submitted: 2003-04-24 01:16 UTC Modified: 2003-04-24 03:16 UTC
From: norm at scratch-pad dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.1 OS: RH Linux 7.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: norm at scratch-pad dot com
New email:
PHP Version: OS:

 

 [2003-04-24 01:16 UTC] norm at scratch-pad dot com
Hi,

We are in the process of migrating to a new machine running PHP 4.3.1 (mysql client API 3.23.49) / Apache 1.3.27 on Red Hat 7.3. We will continue to use the old machine as our mysql box (mysql v. 3.23.54).

We have been getting this sporadic error using this new setup:

Warning: mysql_pconnect() [function.mysql-pconnect]: Link to server lost, unable to reconnect in /path/to/php/file on line 8 

This error has never happened on our existing production machine (PHP 4.2.2 (mysql client API 3.23.39) / Apache 1.3.26 connecting to mysql 3.23.54 locally)

I've searched the bug reports and looks like there are some bugs that were reported in php 4.3.0 which were supposedly fixed:

http://bugs.php.net/bug.php?id=21878
http://bugs.php.net/bug.php?id=21498

Any insight is appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-24 03:12 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


Those bugs are fixed in CVS. Don't report this again.
(get the latest STABLE cvs snapshot from http://snaps.php.net)

 [2003-04-24 03:15 UTC] norm at scratch-pad dot com
FYI we just tried PHP 4.2.3 on the new machine and the errors seem to have gone away.
 [2003-04-24 03:16 UTC] sniper@php.net
Please don't reopen this..

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Oct 02 00:05:51 2022 UTC