php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23290 QuickForm: Select box defaults
Submitted: 2003-04-20 19:41 UTC Modified: 2003-04-20 21:26 UTC
From: jon at jellybob dot co dot uk Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.1 OS: Debian 3.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jon at jellybob dot co dot uk
New email:
PHP Version: OS:

 

 [2003-04-20 19:41 UTC] jon at jellybob dot co dot uk
It seems that setting values for select elements is broken in 3.0, it causes the option(s) defined in setValue to have the attribute 0="selected" in their tag.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-20 21:26 UTC] jellybob@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 08:01:25 2021 UTC