php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23289 variables from form doest not works
Submitted: 2003-04-20 19:28 UTC Modified: 2003-04-20 19:32 UTC
From: alexeytarasov at mail dot primorye dot ru Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.3.1 OS: Win2000/WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
22 - 8 = ?
Subscribe to this entry?

 
 [2003-04-20 19:28 UTC] alexeytarasov at mail dot primorye dot ru
IIS 5
variables from form don't pass

when I launch this code

<? if (!@$name):?>
<form name="form1" method="post" action="test.php">
  Name<br>
  <input name="name" type="text" id="name"><br>
  <input type="submit" name="Submit" value="Submit">
</form>
<? die; endif;
echo "it works!";
?>

Message "it works!" never appears, because variable $name will never be defined, whatever I did.

This problem appears in PHP 4.2 and PHP 4.3, but not in PHP 4.1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-20 19:32 UTC] edink@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
'off'. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.

.
 [2003-04-20 19:32 UTC] pollita@php.net
As of PHP 4.2 the default value for register_globals is off.  Either turn on register_globals or access form elements via the $_GET, $_POST, or $_REQUEST arrays. ($HTTP_*_VARS in PHP 4.2)
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 19:01:29 2024 UTC