php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23267 mysql select bug with accentuated letters
Submitted: 2003-04-18 04:45 UTC Modified: 2003-04-18 11:00 UTC
From: lysander at faker dot hu Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.1 OS: Win XP prof
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lysander at faker dot hu
New email:
PHP Version: OS:

 

 [2003-04-18 04:45 UTC] lysander at faker dot hu
My problem is the next:

if I use mysql_query("SELECT pass FROM regusers WHERE user='g?b'")

it converts down somehow my accentuated a letter. ? -> a and gives back the result of the row where the username is "gab" istead of "g?b" (a row with user g?b does not exists)

phpmyadmin does the same "mistake", of course.

in a mysql client it works fine.
mysql> select pass from regusers where user='g?b';
Empty set (0.07 sec)

I've tried this at debian linux too, with other versions, it does exactly the same.

what is the problem then? I hope not a bug, that would be better if I made a mistake.

Please check me back as soon as possible.
Lysander

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-18 11:00 UTC] georg@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

In the bundled mysql library only charset latin1 is 
supported. In this charset ? and a have the same collating 
order.

Solution: use external mysql library with csas charsets 
(case sensitive, accent sensitive)

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 04:05:54 2022 UTC