php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23169 SQLCODE=-1802 Connection name in use.
Submitted: 2003-04-11 10:15 UTC Modified: 2003-07-20 10:38 UTC
Votes:53
Avg. Score:4.0 ± 1.0
Reproduced:21 of 21 (100.0%)
Same Version:16 (76.2%)
Same OS:11 (52.4%)
From: varkab at yahoo dot com Assigned:
Status: No Feedback Package: Informix related
PHP Version: 4.3.1 OS: SunOS 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: varkab at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-04-11 10:15 UTC] varkab at yahoo dot com
Additional information:
SunOS 5.8,
Web Server iPlanet4.1,
DB-Informix 9.
 
Problem: After restart WebServer the first connection always is fine and get some data, after refresh or open new connection (in spite of closed previous or not) mostly got this error: ---SQLCODE=-1802 Connection name in use---
 and only occasional (rare)connection continuously trying to refresh button in browser. 
I tried with Allow and prevent persistent links in php.ini
and ifx_connect() and ifx_pconnect(). 
When I do connect and retrieve data from command line, no problem, the connection always is fine.
Any suggestion?

 Thanks,
Var 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-29 08:12 UTC] varkab at yahoo dot com
I tried. Didn't help.
I wonder, if someone has same configuration (solaris8,iPlanet4.1 and DB-Informix 9) and doesn't have
any problem?

Thanks.
 [2003-07-12 23:52 UTC] sniper@php.net
Get the latest snapshot and try this with CLI binary.
(NOT within webserver)

You should also try some better supported webserver, such as
Apache 1.3.27..

 [2003-07-20 10:38 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-08-11 06:30 UTC] mainliner_0101 at hotmail dot com
PHP Version 4.3.3RC4
Apache 1.3.27 on windows 98
Informix Dynamic Server 7.31TC4 on Windows NT

same problem exists...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 16:03:35 2021 UTC