|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23118 dbsetlname relocation error
Submitted: 2003-04-08 16:41 UTC Modified: 2003-04-08 19:54 UTC
From: ascott at hemlock dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.2RC1 OS: Linux RedHat 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: ascott at hemlock dot com
New email:
PHP Version: OS:


 [2003-04-08 16:41 UTC] ascott at hemlock dot com
Compile freetds 0.61 with ./configure --prefix=/usr/local/freetds --with-tdsver=7 --enable msdlib
make check 
make install

Everything works ok.

Compile php-4.3.2RC1 with ./configure --with-apache=../apache --with-mssql=/usr/local/freetds --with-mysql=/usr/local/mysql --enable-track-vars
make install

Compile Apache-1.3.27 with ./configure --with-layout=Apache --prefix=/usr/local/apache --activate-module=src/modules/php4/libphp4.a
make install

All of the above make cleanly and install cleanly.  However, whenever I try to access a page with mssql functions in, the  following error is displayed in the error_log file..

/usr/local/apache/bin/httpd: relocation error: /usr/local/apache/bin/httpd: undefined symbol: dbsetlname

However MySQL functions do work.

I tried to compile a version of php & apache with no mysql support and just mssql support but i get the same error.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-08 17:22 UTC] ascott at hemlock dot com
Started from scratch on new system and works.
 [2003-04-08 19:54 UTC]
Not PHP bug -> bogus.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 25 22:01:29 2024 UTC