php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23089 Compiling with aspell 0.50.3 fails
Submitted: 2003-04-07 09:19 UTC Modified: 2005-02-17 04:52 UTC
From: dswhite42 at yahoo dot com Assigned:
Status: Closed Package: Pspell related
PHP Version: 4.3.1 OS: SunOS 5.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dswhite42 at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-04-07 09:19 UTC] dswhite42 at yahoo dot com
When compiling with aspell-0.50.3 (using --with-pspell), everything works fine until the final stages (when sapi/cli/php is created).  At that  point I get multiple errors such as:

Undefined                       first referenced
 symbol                             in file
aspell_speller_store_replacement    ext/pspell/pspell.lo
aspell_speller_add_to_session       ext/pspell/pspell.lo
delete_aspell_speller               ext/pspell/pspell.lo
...
etc.  It appears that the problem is that PHP is including the pspell library but not the newer aspell library, where all those symbols can be found.

The solution that worked for me was to edit the "configure" script, find the section where "-lpspell" is prepended to the $LIBS variables, and add "-laspell" as well.  e.g. on line 62147 for PHP 4.3.1's "configure file", change:

      LIBS="-lpspell $LIBS"
to
      LIBS="-laspell -lpspell $LIBS"




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-17 04:52 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Dec 19 08:01:27 2018 UTC